DiskWarrior

Licence: Commercial with demo
Version 4.4 | Release Date: 2011-10-10 | Download

11/05/2012 - DiskWarrior 4 version 4.4 Compatible with Fusion Drive
DiskWarrior 4 version 4.4 was released last year and is required to repair the directory of a Fusion Drive. You must be started from OS X 10.8.2 Mountain Lion, or later, to rebuild the directory of a Fusion Drive. If you haven't already done so, you can use the free updater for existing owners of DiskWarrior 4 versions 4.0-4.3.

07/25/2012 - DiskWarrior 4 version 4.4 Compatible with OS X 10.8 Mountain Lion
DiskWarrior 4 version 4.4 was released last September and is required to run an installed copy of DiskWarrior while started from 10.8 Mountain Lion. If you haven't already done so, you can use the free updater for existing owners of DiskWarrior 4 versions 4.0-4.3.

07/25/2012 - DiskWarrior 4 version 4.4 and Gatekeeper
Gatekeeper is a new feature of OS X 10.8 Mountain Lion that helps protect you from downloading and installing malicious software on your Mac. Developers can now digitally "sign" their applications so that they are identified as being produced by a known developer such as Alsoft. If a downloaded application is signed by an identified developer, the default behavior of Gatekeeper is to allow you to use the application. Downloaded applications that are not signed cannot be used with a simple double click.

As of today, all copies of DiskWarrior and the DiskWarrior 4 version 4.4 updater that are downloaded from the Alsoft site are digitally signed. This allows you to run these downloaded applications by simply double clicking as you normally would.

What about older downloaded copies of DiskWarrior? Gatekeeper only checks to see if a downloaded application is okay to run if it has not been run before. So you don't need to do anything with older copies of DiskWarrior that you have installed and run prior to installing OS X 10.8 Mountain Lion. If you install an older downloaded copy of DiskWarrior after installing OS X 10.8 Mountain Lion then you can indicate to Gatekeeper that it's okay to run DiskWarrior by control (or right) clicking on the DiskWarrior application and choosing open from the pop-up menu that appears. You'll only need to control (or right) click the first time you run the older downloaded copy of DiskWarrior.

What about DiskWarrior on a DVD or CD? Applications on DVD are not downloaded and therefore are not checked by Gatekeeper.

10/10/2011 - New DiskWarrior 4 version 4.4 Released
DiskWarrior 4 version 4.4 is now available. This release features ongoing internal enhancements for speed and improved repair. A free updater for existing owners of DiskWarrior 4 versions 4.0-4.3 is also available for immediate download (see below).

10/10/2011 - Free DiskWarrior 4 version 4.4 Disc Updater Available
Owners of DiskWarrior 4 versions 4.0-4.3 can now download a free disc update to update to DiskWarrior 4 version 4.4. This free updater application allows you to create a new startup disc (CD/DVD) with the latest version of DiskWarrior using your original DiskWarrior 4.0 to 4.3 disc. This approach provides you with an instant update while maintaining your ability to start up from a disc containing the latest version of DiskWarrior.

The DiskWarrior 4.4 Disc updater cannot update a disc created by any previous DiskWarrior updater. You must update your original (factory) DiskWarrior 4.0 to 4.3 disc. This limitation allows us to reduce the size and complexity of the updater. It also results in a significantly smaller test suite that permits us to issue updates more responsively.

Please note that the new startup disc you create will start up the same set of Mac models as your current DiskWarrior disc (CD/DVD). Your new disc will not start up any Mac that your current DiskWarrior disc can not. If you need a new DiskWarrior disc that can start up the newest Mac models, please contact our Sales Department to order. Please note that you will receive a DVD even if your previous DiskWarrior disc was a CD.

Version 4.2 | Release Date: 2009-08-27 | Download

Full compatibility with Snow Leopard

Version 4.1.1 | Release Date: 2008-10-29 | Download

Version 4.1.1 uses your original 4.0-4.1 CD to create a new startup CD containing DiskWarrior 4 version 4.1.1, which adds Leopard compatibility. The new CD will only start up the same Mac models as the original CD. The included Read Me lists details and requirements.

Version 4.1 | Release Date: 2008-01-26 | Download

Version 4.1 offers additional repair capabilities including the ability to repair damaged directory hard links (a new feature of Leopard for Time Machine backups). DiskWarrior 4 version 4.1 is the only utility that can repair damaged links, directory loops and other problems that can happen with directory hard links.

Owners of DiskWarrior 4 version 4.0 will soon be able to download a free CD updater. When available, this free updater will allow you to create a new startup CD containing the updated DiskWarrior application. Please note that the new startup CD will start up the same set of Macs as your current DiskWarrior CD. Your new CD will not start up any Mac that your current DiskWarrior CD can not.

Running DiskWarrior 4 version 4.1 on a Mac OS X 10.5 (Leopard) startup disk while started from Mac OS X 10.4 (Tiger) or earlier.

If you want or need to run DiskWarrior 4 version 4.1 from Mac OS X 10.4 or earlier, there are two features of DiskWarrior that are not available for a Mac OS X 10.5 startup disk. First, you cannot repair the permissions of a Mac OS X 10.5 startup disk. Second, you cannot rebuild a FileVault that was created under Mac OS X 10.5. You will be able to rebuild a FileVault that was created on a startup disk that was later upgraded to Mac OS X 10.5. Your DiskWarrior CD may start up in Mac OS X 10.4 and would therefore have these features disabled for a Mac OS X 10.5 startup disk. Click here for additional procedures to rebuild the startup disk.

Version 4.0 | Release Date: 2006-12-05 | Download
No changes specified
Version 3.0.3 | Release Date: 2006-07-12 | Download
No changes specified