Comment on Ora Time and Expense

This app now require Adobe AIR 1.0