Comment on GCALDaemon

It says in the title that it's not compatible with Leopard, yet the site has no mention of this. Any comments on it's suitability for Leopard and iCal 3.0? One would think the site itself would have this warning rather than iusethis, but that isn't the case.