Comment on Tags (Gravity Apps)

As of 090120: Doesn't say anywhere on the developer's site, neither here, that this application means no go for people using anything less than OS X 10.5.

But they feel confident enough to talk about usability in their screencast video...