Comment on Glims

Now Glims runs perfectly with the official Safari 4 release.
I like that!

If you want to get the MacUpdate Spring Promo Bundle anyway (like me), you can thank them a little bit easily, by ordering your bundle via this link — I copied it from their Website.

But hurry — it is only a few hours left!
I mean, the bundle will change then. ;-)