Comment on ForkLift

Just a note from the devs: ForkLift fully supports Snow Leopard since release 1.7.5