Comment on Flickr Uploadr

I don't understand: I have 3.2.1 installed (latest available) and AppFresh insists it's 3.1 and wants to upgrade it. Then of course I install the latest version, which I already have, and the version doesn't change.