Comment on YamiPod

Doesn't work with iTunes 9, keeps getting a "firmware not supported" error. This is a major issue with many users:
SEE HERE
A suggested fix of connecting to an iTunes 8 computer first is no use for the many who have upgraded to 9 a long time ago with no ability to downgrade (i.e. most of us).

..until this app is fixed to work with the current iTunes, it's pretty useless for me.