Comment on Opera

10.10 is the current version, however AppFresh is saqying that 10.50 Alpha1 is current. While this may be true, not everyone likes to be on the BLEEDING edge! Isn't there an option to ignore pre-release versions? If not, there should be.