Comment on NeoOffice

Description implies that OpenOffice.org requires X11. This was true in the past, but current versions of OOo for Mac are written in Aqua, no X11 needed. For both PPC & Intel Macs.
OpenOffice.org/Mac