Comment on Gimp

I am running v2.6.8, and AppFresh says I'm out of date and should upgrade ... to v2.6.8. ?