Comment on XQuartz

2 things here: 1) all the comments about the version number seem to be correct. With v2.5.0 installed, I am being prompted to upgrade to "2.5.5", which when downloaded seems to be 2.5.0. Something is wrong there. and 2) XQuartz != X11, and both "upgrades" pulled down the same exact XQuartz package, so, again, I think something is wrong.