Comment on Frostwire

I have 4.20 installed on snow leopard. It keeps showing 1.0 installed. What's happening?