Comment on Transmission

If your updated version won't run on 10.4 on a NON_INTEL mac you should state so so that I know not to update. :P