Comment on Echofon

Version 1.5.1 requires Snow Leopard.
For those still using Leopard, version 1.4.11 works:
http://file.echofon.com/twitter/mac/bin/Echofon_1.4.11.dmg