Comment on Cover Stream

Req. Mac OS X 10.5 Leopard or later, iTunes 7,5 or later.