Comment on Photon

I'm curious whether it will support my Canon Powershot G9 using OS X 10.4.x. I'm not sure that I'll be able to upgrade to 10.5 in the near future. If not, why isn't this possible?