Comment on avidemux

this has officially not required one to have X11 on OS X for several builds now, so the description should be changed to reflect that.